Aller au contenu
Fd_C

News app pour NextCloud (mise à jour des flux via uptader)

Recommended Posts

Le 29/10/2017 à 06:06, Fd_C a dit :

Hello,

Savez-vous s'il est possible d'installer l'updater pour l'app News de NextCloud :
https://github.com/nextcloud/news-updater#installation

Python est annoncé installé sur nos hébergements mais je n'y connais rien :$

En ssh, python3 et pip 3 me remonte un "commande introuvable"

D'avance merci pour votre aide :)

Bonjour,

Ca devrait être bon , nous avons mis l'outil sur les serveurs SSH. 
Vous devriez pouvoir l'utiliser correctement'
 

/opt/alt/python36/bin/nextcloud-news-updater -v
10.0.0


Si vous voulez partager son utilisation plus en détail pour la communauté utilisant les services d'hébergement chez :yulPa ce serait un plus :)

Merci 

  • Like 1

Partager ce message


Lien à poster
Partager sur d’autres sites

Merci Benoît,

Y'a pas à dire, z'êtes vraiment au top :)

Premiers tests avec la commande suivante :

/opt/alt/python36/bin/nextcloud-news-updater /datas/vol1/w4axxxxxx/var/www/path/to/nextcloud

Ça fonctionne mais ne se ferme pas. Obligé de interrompre ou de fermer le terminal comme un cochon.
Deuxième test comme indiqué ici :
 

/opt/alt/python36/bin/nextcloud-news-updater https://domain.com/path/to/nextcloud --user admin_user --password admin_password

Ça fonctionne toujours, la commande se ferme correctement... mais faut un cron pour la relancer toutes les x minutes... Comme Yulpa ne le propose pas encore, j'utilise en attendant les services de setcronjob pour lancer le cron de mon site principal à partir duquel je gère mes autres tâches planifiées. J'ai tenté l'exécution d'un script.sh via exec(); sans résultats. Pas de soucis en SSh mais rien via php. Je suis manchot (oui un peu si vous regardez mon avatar ;)) ou il y a des restrictions.

Du coup, mon cron doit lancer une connexion SSH qui exécute la commande ci-dessus. Ça fonctionne, mes flux sont mis à jour mais ce que j'ai fait n'est franchement pas propre... Je laisse en clair mes identifiants SSH et Admin de mon instance NextCloud sur le serveur.

Du coup, je serais intéressé à savoir si vous avez une visibilité pour la sortie de la fonctionnalité dans iWal ?

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour,

Il y a 3 heures, Fd_C a dit :

Premiers tests avec la commande suivante :


/opt/alt/python36/bin/nextcloud-news-updater /datas/vol1/w4axxxxxx/var/www/path/to/nextcloud

Ça fonctionne mais ne se ferme pas. Obligé de interrompre ou de fermer le terminal comme un cochon.

D'après la documentation, la commande se lance par défaut en mode "endless". Donc rien d'anormal à ce qu'il ne quitte pas. Ce qu'il vous faut, c'est le mode "singlerun".

Il y a 3 heures, Fd_C a dit :

Deuxième test comme indiqué ici :
 


/opt/alt/python36/bin/nextcloud-news-updater https://domain.com/path/to/nextcloud --user admin_user --password admin_password

Ça fonctionne toujours, la commande se ferme correctement... mais faut un cron pour la relancer toutes les x minutes... Comme Yulpa ne le propose pas encore, j'utilise en attendant les services de setcronjob pour lancer le cron de mon site principal à partir duquel je gère mes autres tâches planifiées. J'ai tenté l'exécution d'un script.sh via exec(); sans résultats. Pas de soucis en SSh mais rien via php. Je suis manchot (oui un peu si vous regardez mon avatar ;)) ou il y a des restrictions.

Du coup, mon cron doit lancer une connexion SSH qui exécute la commande ci-dessus. Ça fonctionne, mes flux sont mis à jour mais ce que j'ai fait n'est franchement pas propre... Je laisse en clair mes identifiants SSH et Admin de mon instance NextCloud sur le serveur.

L'environnement d'exécution n'est pas le même entre SSH et HTTP, cela explique sans doute pourquoi cela marche dans un cas et pas dans l'autre :)

A noter qu'il est écrit en toute lettre dans la documentation : "Web Cron is not a supported cron setting since the update process may time out.".

Pas moyen de mettre à jour les flux autrement que par cet utilitaire ?

Partager ce message


Lien à poster
Partager sur d’autres sites

Salut Simon,

Oui, je suis allé un peu vite dans mes retours. Le endless est bien le mode par défaut. Tout fonctionne parfaitement en siglerun, d’où la nécessité d'un cron régulier. Le '--mode singlerun' est bien présent dans ma commande. J'ai copié/collé la commande de la notice dans mon précédent post, d’où l'oubli...

Pour les suivants, ma commande exacte est celle-ci :

/opt/alt/python36/bin/nextcloud-news-updater https://domain.com/path/to/nextcloud --user admin_user --password admin_password --mode singlerun

 

1 hour ago, Simon DUJANCOURT said:

L'environnement d'exécution n'est pas le même entre SSH et HTTP, cela explique sans doute pourquoi cela marche dans un cas et pas dans l'autre :)

Oui, c'est ce que je me suis dis alors je n'ai pas cherché trop longtemps ;)

Je te confirme bien que la mise à jour des flux ne fonctionne pas via le webcron que j'utilise actuellement sur mon instance (qui elle tourne très bien avec ce Webcron). Je ne vois donc pas d'autre moyen pour le moment que de faire ainsi : un cron qui lance une commande nextcloud-news-updater via SSH :/

Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant


×