Aller au contenu
  • 0
irahgis

De l'aide https pour un boulet sous WP svp

Question

Bonjour/Bonsoir à tous ceux qui liront ce message,

Et merci d'avance à ceux qui prendront le temps d'y répondre et qui chercheront à m'aider.

Tout est presque écrit dans le titre du post. Je galère à faire une chose sensée être simple à savoir passer un site WP en ssl.Bon, je suis pas totalement teubé, j'ai d'abord cherché une réponse sur le forum... J'ai donc, comme conseillé, généré le certificat Let's Encrypt avec le manager et celui-ci s'affiche bien dans "Dépôts certificats SSL" avec mon domaine à côté (avec et sans www)

J'ai d'abord installé "Really Simple SSL" en me disant, cool ça va être simple et vite fait l'histoire", le plugin une fois activé m'indique qu'il a bien repéré le certificat ssl et me propose d'activer le ssl. Ensuite, un message m'indique qu'il faut que je me reconnecte en https, eeeeeet là, c'est la cata, c'est la catastrophe.

C'est à partir de ce moment là que j'ai commencé à me transformer en minion...

J'ai perdu l'accès au site et j'ai dû désactiver le plugin dans la bdd avec phpmyadmin et j'ai du viré les https de "nom du site" et "homepage du site" pour récupérer la main.

Je repars de zéro, je me décourage pas, je teste les différentes configurations .htaccess trouvées sur le forum, et sur des sites "spécialisés tuto wp" idem, rien n'y fait, même délire.

Donc, j'ai sorti le legendario histoire de me calmer un peu et me voici en train d'écrire un message d'appel à l'aide ici voir si un maître Jedi pourrait sortir le jeune padawan que je suis de là...

Ah oui, j'oubliais, je suis en redirection HTTP+HTTPS sur iwal.

Voilà, donc si vous pouviez m'aider à retrouver ma forme originale et un peu d'estime de moi, je vous serais très, mais alors très très reconnaissant !

 

Partager ce message


Lien à poster
Partager sur d’autres sites

2 réponses à cette question

Recommended Posts

  • 1

Bonjour à vous, 

Merci de répondre ! 

J'ai résolu mon problème ce matin, je n'ai pas pensé à mettre le topic en résolu.

Pour ceux qui se poserait la question un jour sur comment j'ai fait ?

La réponse est rien (pas de modif du .htaccess, ni de plugin à installer, etc.). Il n'y a rien à faire sur Yulpa pour passer son site WordPress en ssl, à part évidemment les 3 manipulations précitées à savoir:

  1. Générer un certificat Let's Encrypt
  2. Configurer la redirection HTTP+HTTPS
  3. Changer l'url du site et la page d'accueil en "https://lenomdusite.tld"

Mon problème venait du cache d'Opera je pense. J'ai encore quelques soucis de "contenu mixte" sur certaines pages, que je suis en train de résoudre grâce à la console du navigateur mais rien d'irrésolvable à première vue.

Voilà, en espérant que ça serve à quelqu'un.

Merci pour votre sollicitude Aurélien et pour vos services, j'en suis ravi depuis Web4all, vous êtes au top, rien à dire si ce n'est que du bien.

 

 

  • Upvote 1

Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant

×