Christophe

Membres
  • Compteur de contenus

    6
  • Inscription

  • Dernière visite

  • Jours gagnés

    2

Christophe a gagné pour la dernière fois le 8 juin

Christophe a eu le contenu le plus aimé !

Réputation sur la communauté

4 Neutral

À propos de Christophe

  • Rang
    Newbie
  1. Meilleure(s) solution(s) (1 seule redirection/pas de message d'erreur redirection - pour les 4 variantes - au lieu de 2-3 signalés par Google Speed Insights selon les variantes : http://, http://www, https:// ou https://www). Avec le(s) code(s) utilisés par défaut par le CMS en les décommentant et qui marchai(en)t chez un autre hébergeur, il y avait aussi le même problème. Ça a été résolu chez l'autre hébergeur avec : RewriteCond %{SERVER_PORT} 80 RewriteRule ^(.*)$ https://www.domainname.tld/$1 [R=301,L] et RewriteCond %{HTTP_HOST} ^domainname.tld$ RewriteRule ^(.*) https://www.domainname.tld/$1 [QSA,L,R=301] Pour Yulpa, il faut juste rajouter RewriteCond %{HTTP:X-Forwarded-Proto} !https au dessus de RewriteCond %{SERVER_PORT} 80 J'ai testé certaines "variations", mais ça semble marcher moins bien ou ça ne marche plus... Tel que c'est, ça marche bien. Et google, entre autres, est content. NB : chez l'autre hébergeur, en testant, tout inverser pour utiliser la variante non-www au lieu de la www a été simple. Et google speed insights était content aussi. Je n'ai pas testé pour Yulpa avec RewriteCond %{HTTP:X-Forwarded-Proto} !https en plus. À priori ça devrait marcher aussi, mais on ne sait jamais.
  2. Je vous remercie énormément Aurélien. Ça marche. Je cherchais des solutions de mon côté. J'allais presque renoncer à la redirection vers https://www.nomdedomaine.tld. Car, si ma mémoire est bonne/sauf erreur, il n'y avait pas ce problème (ou le même genre de problèmes) pour une redirection vers https://nomdedomaine.tld. J'ai juste rajouté votre code en un bloc (sauf RewriteEngine on déjà activé). J'avais remarqué RewriteCond %{HTTP:X-Forwarded-Proto} !https quelque part, ça concernait - entre autres - le CLOUD, sauf erreur. En enlevant juste RewriteCond %{HTTP:X-Forwarded-Proto} !https, ça ne marche plus de nouveau. Je viens de trouver ça notamment en cherchant rapidement : Bonne fin de semaine ! ProcessWire : @Christophe
  3. Vous m'avez dit que pour mon cas il fallait que sur iWal le domaine soit défini en HTTP+HTTPS, je l'ai donc remis ainsi lundi. Quand je changeais le mode de publication, j'attendais bien que ça soit marqué ok/positif tout en haut. Je viens de réactiver ça (avec RewriteBase / au cas où ça soit nécessaire) il y a environ 15-20 mns : # ----------------------------------------------------------------------------------------------- # 9. If you only want to allow HTTPS, uncomment the RewriteCond and RewriteRule lines below. # ----------------------------------------------------------------------------------------------- RewriteCond %{HTTPS} off RewriteRule (.*) https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301] ET # ----------------------------------------------------------------------------------------------- # 13. OPTIONAL: Redirect users to the 'www.' version of the site (uncomment to enable). # For example: http://processwire.com/ would be redirected to http://www.processwire.com/ # ----------------------------------------------------------------------------------------------- RewriteCond %{HTTP_HOST} !^www\. [NC] RewriteRule ^ http://www.%{HTTP_HOST}%{REQUEST_URI} [L,R=301] Mais les redirections ne fonctionnent pas comme elles sont censées marcher, et comme ça marche ailleurs. Firefox me donne : The page isn’t redirecting properly Firefox has detected that the server is redirecting the request for this address in a way that will never complete. This problem can sometimes be caused by disabling or refusing to accept cookies. Chromium : La page www.nomdedomaine.fr ne fonctionne pas www.nomdedomaine.fr vous a redirigé à de trop nombreuses reprises. Essayez de supprimer les cookies.. ERR_TOO_MANY_REDIRECTS Opera : Cette page ne fonctionne pas nomdedomaine.fr vous a redirigé à de trop nombreuses reprises. Je n'ai aucun moyen de savoir pourquoi ça ne fonctionne pas chez vous. J'ai aussi essayé plusieurs autres règles/directives... Je nettoie le cache, les cookies, etc. Pour le .htaccess, je n'essaie pas seulement une fois quelques secondes après le changement. N'avez-vous pas du code à insérer dans .htaccess à me proposer ou une autre solution pour que ça fonctionne spécifiquement chez vous ? Merci d'avance
  4. Comme déjà expliqué, je ne trouve aucune solution .htaccess qui fonctionne chez YULPA. Chez d'autres, je peux obtenir cette redirection soit seulement avec .htaccess, soit avec .htaccess et le "panel"/l'administration. Ça concerne # 9. et # 13. (ce qui est entre crochets). J'ai essayé pas mal de codes différents, je n'arrive pas à en faire fonctionner chez Yulpa. Avec Let's Encrypt/https, le fait de devoir éviter le "duplicate content", etc., beaucoup de sites doivent maintenant rediriger vers https:// ou https://www (si leur site est avec www., et il y en a beaucoup). Je n'arrive pas à faire rediriger les 3 autres vers https://www. Je viens demander de l'aide car les codes habituels et bien d'autres essayés (solutions Forums CMS, Stack Overflow, etc.) ne semblent pas fonctionner pour une raison ou une autre ici. Je commence à me dire que j'aurais dû essayer juste quelques mois avant, je suis bloqué avec ce problème/détail.
  5. Bonjour, Ce qui me ramène à mon point de départ. J'ai déjà un fichier .htaccess, j'ai essayé en activant certaines choses. J'ai essayé des variantes. J'ai essayé avec des solutions de Stack Overflow, etc. Rien. Et j'ai notamment des messages qui mentionnent trop de redirections, etc. J'ai nettoyé les caches, les cookies... Je teste dans Chromium, firefox, opera... Ce qui aurait été l'idéal c'est une option dans iWal pour choisir HTTPS seulement mais avec tout redirigé vers le sous domaine www. plutôt que la version sans www., ce qui est, à priori, au moins aussi fréquent, sinon plus. Pour l'histoire du duplicate content, tout devrait être redirigé vers un seul choix : https:// ou https://www. J'ai réussi au moins une fois pour un site chez un autre hébergeur avec un "mélange" dans .htaccess et dans l'administration de l'hébergeur (redirection). Avez-vous du code adapté à vos hébergements à rajouter dans .htaccess pour que ça marche. Je cherche et espère aussi une éventuelle solution dans le forum du CMS, mais ça dépend aussi de l'hébergement. Je serai bien embêté si je n'y arrive pas car j'ai au moins un autre site à venir. Let's Encrypt sans cette possibilité perd de son intérêt aussi. [ Édition : Le nom de domaine et le webmail sont chez gandi. Chez un autre hébergeur, ça marche en activant : # ----------------------------------------------------------------------------------------------- # 9. If you only want to allow HTTPS, uncomment the RewriteCond and RewriteRule lines below. # ----------------------------------------------------------------------------------------------- RewriteCond %{HTTPS} off RewriteRule (.*) https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301] ET # ----------------------------------------------------------------------------------------------- # 13. OPTIONAL: Redirect users to the 'www.' version of the site (uncomment to enable). # For example: http://processwire.com/ would be redirected to http://www.processwire.com/ # ----------------------------------------------------------------------------------------------- RewriteCond %{HTTP_HOST} !^www\. [NC] RewriteRule ^ http://www.%{HTTP_HOST}%{REQUEST_URI} [L,R=301] (sans avoir besoin de RewriteBase /) Ici je ne peux à priori pas utiliser l'un avec l'autre. ] Bonne journée ! NB : en pièce jointe, le .htaccess par défaut htaccess.txt
  6. Bonjour, Avec Yulpa, je n'arrive pas à rediriger comme d'habitude avec les directives/règles que j'active parfois dans le .htaccess du CMS/CMF que j'utilise (ProcessWire). J'ai essayé avec plusieurs variantes et même depuis iWal avec Mode de publication HTTP redirige sur HTTPS que j'ai supprimé ensuite. Aujourd'hui je viens de remettre Mode de publication HTTP redirige sur HTTPS. http://nomdedomaine.fr est redirigé vers https://nomdedomaine.fr http://www.nomdedomaine.fr est redirigé vers https://nomdedomaine.fr https://nomdedomaine.fr est accessible et https://www.nomdedomaine.fr aussi. J'ai besoin que : http://nomdedomaine.fr et http://www.nomdedomaine.fr soit redirigés vers https://www.nomdedomaine.fr https://nomdedomaine.fr soit redirigé vers https://www.nomdedomaine.fr Donc que tout soit redirigé vers https://www.nomdedomaine.fr. Je n'arrive pas à le faire fonctionner comme chez d'autres hébergeurs. Merci d'avance pour votre aide. NB : http vers https, ça doit en effet être une "PERMANENT REDIRECT".