Aller au contenu

nkiefer

Membres
  • Compteur de contenus

    19
  • Inscription

  • Dernière visite

  • Jours gagnés

    5

nkiefer a gagné pour la dernière fois le 24 mai

nkiefer a eu le contenu le plus aimé !

Réputation sur la communauté

6 Neutral

À propos de nkiefer

  • Rang
    Newbie
  • Date de naissance 15 février
  1. Connexion via phpMyAdmin

    Bonsoir, Pour te connecter tu dois : Utiliser le même nom d'utilisateur (et mot de passe) que celui de ta base de donnée MySQL (tu trouvera ces infos dans iWal) Sélectionner (menu déroulant) le serveur sur lequel est stocké ta base Normalement ça devrait fonctionner. Cordialement.
  2. Certificat & Sous-domaine

    Bonjour, Oui, c'est possible de la même manière que pour le domaine principal. Je l'ai fait pour mes 2 sous-domaines. Il m'a juste fallu supprimer le serveur alias "www" de mes sous-domaines avant de générer le certificat. Plus d'info à ce sujet : Bonne journée. Cordialement.
  3. Bloc-notes dans iWal

    C'est l'idée, une sorte de whiteboard
  4. Bloc-notes dans iWal

    Le but de la proposition n'est pas de créer un bloc-notes pour noter sa liste de courses ou autres futilités, mais d'avoir un espace où laisser une note en lien avec l'administration de l'hébergement. Pas d'onglet, un truc tout simple, qui permet par exemple de noter la date d'une modification faite sur la config, de noter un paramètre pour ne pas l'oublier. C'est dans ce but que j'ai mis en place le bloc-notes sur mon site. C'est grosso modo une textarea avec mise en forme. Bonne journée. Nicolas
  5. Bloc-notes dans iWal

    Bonsoir, Je relance une idée que j'avais soumise sur le forum de Web4all concernant iWal 2 : Une zone bloc-notes permettant de conserver des notes dans notre espace membre. J'ai mis en place un système similaire sur l'espace admin de mon site : J'utilise CKEditor pour la fenêtre du bloc-notes et TCPDF pour pouvoir exporter mon mémo en PDF. Voilà voilà ma petite proposition pour rendre iWal 2 toujours plus unique Bonne soirée. Nicolas
  6. [Résolu] Suppression d'un dossier impossible

    Merci Aurélien ! Le dossier a pu être supprimé Une idée du pourquoi du comment le dossier c'est bloqué ? C'est arrivé après avoir supprimer le sous-domaine dans iWal. Bonne journée. Cordialement.
  7. [Résolu] Suppression d'un dossier impossible

    Bonjour, En SFTP, les permissions sur ce dossier sont les suivantes : Mais je ne les ai pas volontairement changées pour ce dossier ... Je ne sais pas d'où ça sort ? Cordialement.
  8. Bonsoir, J'ai un problème avec un dossier sur mon hébergement : il est impossible de le supprimer ... Via SSH : [w4a118450@web4all.fr www]$ rm -rf galeries.nkiefer.jed.st rm: cannot remove `galeries.nkiefer.jed.st/cgi-bin': Permission denied rm: cannot remove `galeries.nkiefer.jed.st/htdocs': Permission denied Via FTP : Statut : Récupération du contenu du dossier "/var/www/galeries.nkiefer.jed.st"... Statut : Contenu du dossier "/var/www/galeries.nkiefer.jed.st" affiché avec succès Statut : Récupération du contenu du dossier "/var/www/galeries.nkiefer.jed.st/cgi-bin"... Statut : Contenu du dossier "/var/www/galeries.nkiefer.jed.st/cgi-bin" affiché avec succès Commande : CWD /var/www/galeries.nkiefer.jed.st Réponse : 250 OK. Current directory is /var/www/galeries.nkiefer.jed.st Commande : PWD Réponse : 257 "/var/www/galeries.nkiefer.jed.st" is your current location Commande : RMD cgi-bin Réponse : 550 Can't remove directory: Permission denied Statut : Récupération du contenu du dossier "/var/www/galeries.nkiefer.jed.st/htdocs"... Statut : Contenu du dossier "/var/www/galeries.nkiefer.jed.st/htdocs" affiché avec succès Commande : CWD /var/www/galeries.nkiefer.jed.st Réponse : 250 OK. Current directory is /var/www/galeries.nkiefer.jed.st Commande : RMD htdocs Réponse : 550 Can't remove directory: Permission denied Commande : CWD /var/www Réponse : 250 OK. Current directory is /var/www Commande : PWD Réponse : 257 "/var/www" is your current location Commande : RMD galeries.nkiefer.jed.st Réponse : 550 Can't remove directory: Directory not empty Statut : Récupération du contenu du dossier "/var/www"... Statut : Contenu du dossier "/var/www" affiché avec succès Via SFTP : Statut : Récupération du contenu du dossier "/datas/vol2/kiefer.jed.st/var/www/galeries.nkiefer.jed.st"... Statut : Listing directory /datas/vol2/kiefer.jed.st/var/www/galeries.nkiefer.jed.st Statut : Contenu du dossier "/datas/vol2/kiefer.jed.st/var/www/galeries.nkiefer.jed.st" affiché avec succès Statut : Récupération du contenu du dossier "/datas/vol2/kiefer.jed.st/var/www/galeries.nkiefer.jed.st/cgi-bin"... Statut : Contenu du dossier "/datas/vol2/kiefer.jed.st/var/www/galeries.nkiefer.jed.st/cgi-bin" affiché avec succès Commande : rmdir "/datas/vol2/kiefer.jed.st/var/www/galeries.nkiefer.jed.st/cgi-bin" Erreur : rmdir /datas/vol2/kiefer.jed.st/var/www/galeries.nkiefer.jed.st/cgi-bin: permission denied Statut : Récupération du contenu du dossier "/datas/vol2/kiefer.jed.st/var/www/galeries.nkiefer.jed.st/htdocs"... Statut : Contenu du dossier "/datas/vol2/kiefer.jed.st/var/www/galeries.nkiefer.jed.st/htdocs" affiché avec succès Commande : rmdir "/datas/vol2/kiefer.jed.st/var/www/galeries.nkiefer.jed.st/htdocs" Erreur : rmdir /datas/vol2/kiefer.jed.st/var/www/galeries.nkiefer.jed.st/htdocs: permission denied Commande : rmdir "/datas/vol2/kiefer.jed.st/var/www/galeries.nkiefer.jed.st" Erreur : rmdir /datas/vol2/kiefer.jed.st/var/www/galeries.nkiefer.jed.st: received failure with description 'Failure' Statut : Récupération du contenu du dossier "/datas/vol2/kiefer.jed.st/var/www"... Statut : Listing directory /datas/vol2/kiefer.jed.st/var/www Statut : Contenu du dossier "/datas/vol2/kiefer.jed.st/var/www" affiché avec succès J'ai ouvert un ticket, mais j'ai peut être raté quelque chose qui me permettrait de le supprimer ce satané dossier. Une suggestion ? Pourquoi ce dossier s'est verrouillé ? Je vous remercie. Cordialement. Nicolas
  9. Script formulaire contact

    Bon, je pense avoir trouvé le problème : J'ai remplacé $HTTP_POST_VARS['xxx'] par $_POST['xxx'] et tout fonctionne. Autre question : Quelqu'un sait comment personnaliser (en PHP) le nom afficher (Web4all dans l'exemple ci-dessous) : Je vous remercie. Cordialement.
  10. Bonjour, Le script ci-dessous fonctionne parfaitement en PHP 5.3, mais ne fonctionne plus en PHP 7.0 ... <?php // Formulaire de contact du site Lengrau Internet // http://www.nkiefer.jed.st // // Copyright (C) Kiefer 2014 // Tous droits réservés // MEMORISER LES CHAMPS DU FORMULAIRE DANS DES VARIABLES // PREVENTION CONTRE VULNERABILITE XSS (CROSS-SITE SCRIPTING) $trans = array("&" => "et"); $nom = strip_tags(strtr($HTTP_POST_VARS['nom'], $trans)); $mail_exp = strip_tags(strtr($HTTP_POST_VARS['email'], $trans)); $sujet = strip_tags(strtr($HTTP_POST_VARS['sujet'], $trans)); $message = strip_tags(strtr($HTTP_POST_VARS['message'], $trans)); $secure_hp = strip_tags(strtr($HTTP_POST_VARS['contact_validation_id1'], $trans)); // ENCODER TEXTE EN UTF-8 $nom = utf8_decode($nom); $sujet = utf8_decode($sujet); $message = utf8_decode($message); // MEMORISER L'IP DE L'EXPEDITEUR DU MESSAGE $ip = $_SERVER['REMOTE_ADDR']; // COUPE LES LIGNES DE PLUS DE 70 CARACTERES DANS LE MESSAGE $message = wordwrap($message, 70, "\r\n"); // HEADER MAIL WEBMASTER $headers = "MIME-Version: 1.0\r\n"; $headers = "Content-type: text/plain; charset=utf-8"."\r\n"; $headers = "From: $nom <$mail_exp>\r\nReply-to : $nom <$mail_exp>\nX-Mailer:PHP"; // HEADER MAIL EXPEDITEUR $headers_exp = "MIME-Version: 1.0\r\n"; $headers_exp = "Content-type: text/plain; charset=utf-8"."\r\n"; $headers_exp = "From: $nom <$mail_exp>\r\nReply-to : $nom <$mail_exp>\nX-Mailer:PHP"; // PARAMETRES DU MESSAGE WEBMASTER $subject = "[LENGRAU INTERNET] ".utf8_encode($sujet); $mail_web = "xxx@nkiefer.jed.st"; $body = "Message envoyé depuis le formulaire de contact de Lengrau Internet."."\r\n\r\n"."-----"."\r\n\r\n"."* Nom .......... : ".utf8_encode($nom)."\r\n"."* Sujet ........ : ".utf8_encode($sujet)."\r\n"."* Email ........ : $mail_exp"."\r\n"."* Adresse IP ... : $ip"."\r\n\r\n"."-----"."\r\n\r\n".utf8_encode($message); // PARAMETRES DU MESSAGE EXPEDITEUR $subject_exp = "[LENGRAU INTERNET] Confirmation d'envoi de votre message : ".utf8_encode($sujet); $body_exp = "Confirmation d'envoi de votre message (".utf8_encode($sujet).") envoyé depuis le formulaire de contact du site Lengrau Internet (www.nkiefer.jed.st)."."\r\n\r\n"."-----"."\r\n\r\n".utf8_encode($message)."\r\n\r\n"."-----"."\r\n\r\n"."Votre adresse IP ($ip) a été transmise au webmaster de Lengrau Internet."; // DEBUT CONDITION CHAMPS VIDES if (!empty($_POST['nom']) && !empty($_POST['email']) && !empty($_POST['sujet']) && !empty($_POST['message'])) { $adresse = htmlentities($_POST['$mail_exp']); // DEBUT CONDITION EMAIL INVALIDE if(VerifierAdresseMail($mail_exp)) { // DEBUT CONDITION ANTIBOT if(empty($_POST['contact_validation_id1']) && isset($_POST['contact_validation_id2'])) { // DEBUT CONDITION ENVOI if (mail($mail_web,$subject,utf8_decode($body),$headers) && mail($mail_exp,$subject_exp,utf8_decode($body_exp),$headers_exp)) { header("location:../contact.html?mail=1"); // Réussite de l'envoi } else { header("location:../contact.html?mail=-1"); // Echec de l'envoi } // FIN CONDITION ENVOI } else { header("location:../contact.html?mail=-8"); // Erreur si robot } // FIN CONDITION ANTIBOT } else { header("location:../contact.html?mail=-4"); // Erreur si email invalide } // FIN CONDITION EMAIL INVALIDE } else { header("location:../contact.html?mail=-2"); // Erreur si champs vides } // FIN CONDITION CHAMPS VIDES // VERIFICATION DE LA SYNTAXE DE L'EMAIL function VerifierAdresseMail($email) { $syntaxe = "#^[a-z0-9._-]+@[a-z0-9._-]{2,}\.[a-z]{2,4}$#"; if(preg_match($syntaxe,$email)) return true; else return false; } ?> Je me retrouve avec une erreur "Erreur si email invalide" ou avec l'erreur "Echec de l'envoi". C'est un script que j'ai écrit moi-même, mais là je ne vois pas ce qui cloche avec cette version de PHP. A priori les fonctions utilisées sont toujours d'actualité en PHP 7.0. Quelqu'un a un petite idée du pourquoi du comment ? Je vous remercie. Cordialement. Bon dimanche. Nicolas
  11. Bonjour, Merci Kerweb pour ta réponse. C'était presque ça : au lieu d'utiliser #modal, j'ai ajouter "position", "bottom" et "right" au script fancyBox de la page en question : <script> $("[data-fancybox]").fancybox({ fullScreen : false, iframe : { css : { width : '496px', height : '328px', position: 'absolute', bottom: '6px', right: '50px' } } }); </script> Et tout fonctionne comme je le souhaite Sujet résolu. Bonne soirée à tous. Cordialement. Nicolas
  12. Bonsoir, Je poste dans la section "Utilisation de CMS (Joomla, Wordpress, Drupal....)", car il n'y a pas de section pour ceux qui n'utilisent pas de CMS Sur mon site, j'utilise le script "fancyBox 3". Pour une page particulière, je souhaiterai que l'iFrame qui s'affiche dans la lightbox ne soit pas centré sur l'écran, mais à une distance (ou pourcentage) donnée du bas droit de l'écran (le principe doit être le même si on veut le haut gauche). Je n'ai rien trouvé au niveau des options indiquées dans la doc sur le site de fancyBox. Est-ce que quelqu'un a une piste ou a déjà fait cela ? C'est un besoin un peu particulier, j'en conviens, mais on trouve de tout dans la nature Je vous remercie. Cordialement. Nicolas
  13. [RESOLU]SQLite

    Bonsoir, Merci Simon pour ta réponse. J'ai laissé tombé "Quick PHP Chat" pour "Live Shout" et tout fonctionne comme je le souhaite. Bonne soirée. Cordialement. Nicolas
  14. [RESOLU]SQLite

    Bonjour, J'ai voulu tester un script de shoutbox (Quick PHP Chat pour ne pas le citer) et lors de l'exécution je tombe sur l'erreur suivante : Fatal error: Call to undefined function sqlite_open() in /datas/vol2/kiefer.jed.st/var/www/nkiefer.jed.st/subdomains/www/html/chat/ajax/db.php on line 7 D'après la doc du script : Est-ce que le module SQLite est installé et activé par défaut sur les hébergements :yulPa ? Je vous remercie. Cordialement. Nicolas
  15. Bonjour Plow, Sur mon site (qui n'est pas en Wordpress), j'ai utilisé la syntaxe suivante : # ---------------------------- # -- FORCER UTILISATION HTTPS # ---------------------------- RewriteEngine On RewriteCond %{HTTP:X-Forwarded-Proto} !https RewriteCond %{HTTPS} !on RewriteRule ^(.*) https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301] Et ça a l'air de fonctionner. La ligne "RewriteRule" est différente. Je ne sais pas si ta syntaxe est mieux que la mienne. Cordialement. Nicolas
×