Jump to content

jnm

Members
  • Content Count

    8
  • Joined

  • Last visited

Community Reputation

0 Neutral

About jnm

  • Rank
    Newbie

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. Merci Mickelebof, j'avais bien vu ce post consacré à l'install de wallabag. J''ai bien créé le fichier php.ini dans le répertoire de mon sous-domaine (sous domaine qui est en php7.1), à partir du php ini du manager iwal. Les fichiers d'install et de setup se sont bien téléchargés comme l'indique un "ls" sur la racine de ce sous-domaine: voici ce que donne le ls: cgi-bin composer-setup.php htdocs php.ini Mais le message d'erreur est identique: w4axxxxxxxx@ssh1.yulpa.io:/datas/vol3/w4axxxxxx/var/www/forum.at06.eu $ php71 -c /datas/vol3/w4axxxxxxx/var/www/forum.at06.eu/php.ini composer-setup.php Some settings on your machine make Composer unable to work properly. Make sure that you fix the issues listed below and run this script again: The json extension is missing. Install it or recompile php without --disable-json The phar extension is missing. Install it or recompile php without --disable-phar En effet, un "php71 -m" montre que ces extensions ne sont pas chargées et pourtant l'édition du php.ini qui est dans le dossier de ce sous-domaine montre bien qu'il contient les extensions phar et json
  2. Voici ce que cela donne xxxxxxxx@ssh1.yulpa.io:~ $ php71 composer-setup Could not open input file: composer-setup xxxxxxxx@ssh1.yulpa.io:~ $ php71 composer-setup.php Some settings on your machine make Composer unable to work properly. Make sure that you fix the issues listed below and run this script again: The json extension is missing. Install it or recompile php without --disable-json The phar extension is missing. Install it or recompile php without --disable-phar Ces deux extensions sont pourtant activées d'après le php.ini visible sur iwal
  3. Bonjour Je cherche à installer Composer pour installer un moteur de forum genre Flarum sur un sous-domaine avec PHP 7.1. J'ai essayé d'installer Composer en ssh à partir d'un post de ce forum pour une install de nextcloud sur ce forum, mais je bute sur les messages d'erreur suivants quand je fais un php -m, il n'y a pas phar et json, alors que le php.ini du sous-domaine sur Iwal indique qu'ils sont installés. voyez vous une solution ? merci pour vos réponses.
  4. Est-ce que quelqu'un a réussi à installer Flarum ? Pour installer Flarum, il ne manquerait pas grand chose: Flarum nécessite PHP 7.1 et MySQL 5.6+. ou MariaDB 10.0.5+ https://flarum.org/docs/install.html#server-requirements mais je lis sur iwal qu'on est en PHP 7.0 et MariaDB 5.5.6 il faudrait ensuite pouvoir installer Composer en SSH, ce qui semble faisable d'après ce post et enfin il faudrait installer l'extension openssl dans le php.ini est-ce quand même faisable à votre avis ?. Je sais faire du copier-coller dans un terminal en ssh avec mon hébergement, mais pas plus. Merci de votre avis.
  5. Agora-project fonctionne très bien aussi sur le mutualisé, et est utilisé par de nombreux établissements scolaires
  6. Bonjour, Est-il possible d'avoir un lien d'auto-inscription et auto-désinscription sur les listes ? (comme avec sympa ou mailman) cela permettrait aux utilisateurs de s'abonner et se désabonner eux-mêmes. merci
×
×
  • Create New...