Jump to content

Probleme sauvegarde Dolibarr


Recommended Posts

Bonjour.

J'utilise Dolibarr sur un hébergement mutualisé. Depuis quelques semaines j'ai un problème pour effectuer une sauvegarde par mysqldump.

Lorsque je tente de le faire, j'ai un message d'erreur : "Erreur : Échec de l'exécution de commande externe. Vérifiez qu'elle est disponible et exécutable par l'utilisateur de votre serveur PHP. Vérifiez également que la commande n'est pas protégée au niveau du shell par une couche de sécurité comme apparmor."

Dolibarr affiche la commande qui est lancée : usr/bin/mysqldump 140088_dolibarr -h mysql3.yulpa.io -u 140088_dolibarr -P 3306 -l --single-transaction --add-drop-table=TRUE --tables -c -e --hex-blob --default-character-set=utf8 --no-tablespaces -p"**********"

J'ai lancé cette commande depuis un terminal en connexion SSH en redirigeant la sortie dans un ifchier . L'éxécution démarre, et retourne une erreur : "mysqldump: Couldn't execute 'SELECT COLUMN_NAME,                       JSON_EXTRACT(HISTOGRAM, '$."number-of-buckets-specified"')                FROM information_schema.COLUMN_STATISTICS                WHERE SCHEMA_NAME = '140088_dolibarr' AND TABLE_NAME = 'llx_accounting_account';': Unknown table 'COLUMN_STATISTICS' in information_schema (1109)"

Sur un forum Dolibarr, j'ai demandé de l'aide, et on m'a conseillé de créer à la racine de mon compte un fichier ".my.cnf" contenant : "[mysqldump] column-statistics=0". C'est ce que j'ai fait.

J'ai ensuite relancé la commande depuis le terminal. Elle s'exécute sans retourner d'erreur.

Mais si je relance la commande depuis Dolibarr, j'ai toujours la même erreur.

Je pense que la directive dans le fichier ".my.cnf" n'est pas prise en compte lorsque la commande est lancée depuis Dolibarr. J'imagine que c'est liée à l'utilisateur qui exécute Dolibarr (PHPH et/ou MYSQL)... Mais là, ça dépasse de beaucoup mes compétences, alors j'espère trouver ici quelqu'un qui peut m'aider!

Merci d'avance pour tous vos conseils.

JF

Link to comment
Share on other sites

Bonjour,

Je viens d'essayer, même résultat. J'ai essayé Gzip - Bzip et Aucune compression, rien ne fonctionne.

Par contre, j'ai une sauvegarde datant du de 2020. Cela veut donc dire que ça fonctionnait avant...

Le mieux c'est d'ouvrir un ticket sur Iwal. 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...