Jump to content
  • 0

Erreur Joomla 4 et php 8


jf.duprat
 Share

Question

Bonjour.

sur un hebergement mutualisé, j'ai fait un essai de migration d'un petit site de Joomla 3 à Joomla 4 en suivant une doc de joomla.org. Après quelques tatonnements et adaptations, ça fonctionne, mais en php 7.4.14. Dans IWAL, j'ai mofifié la version de php pour passer en 8.0. Et là mon site est inaccessible, idem coté administration. J'ai des erreurs 500 :

- le premier accès : Attempted to load interface "JsonSerializable" from the global namespace. Did you forget a "use" statement?

- et si je retente : Attempted to call function "simplexml_load_file" from namespace "Joomla\CMS\Language".

Quelqu'un peut il m'aiguiller pour résoudre ce problème?
Est-ce qu'il vaut mieux rester sur le php 7.4?

Merci pour vos propositions!

 

 

 

Link to comment
Share on other sites

3 answers to this question

Recommended Posts

  • 0

Bonjour jf.duprat,

je n'ai malheureusement pas la réponse à votre question et j'espère que vous allez trouver une solution.

Néanmoins pourriez vous me dire quelle documentation de joomla.org vous avez utilisé pour réaliser votre migration. je cherche à réaliser cette opération et pour l'instant la mise à jour en automatique m'est impossible. En vous remerciant de votre réponse je vous souhaite une très belle journée

Cordialement . 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...