Jump to content
  • 0
LG92

PYDIO erreur Missing user in node URL

Question

Salut à tous,

Je suis un ancien de Web4All et utilisateur de Pydio (ex Ajaxplorer, c'est un CMS de gestion de fichiers). L'ancienne installation avait traversé la migration vers Yulpa mais en voulant m'en resservir elle s'est mis à ne plus fonctionner malgré ou à cause de mises a jour. J'ai donc décidé de la réinstaller de zero Pydio 8.0.2 sur un de mes sous-domaine (**PHP 7.0 - MySQL6 mariaDB 5.5**).

L'installation s'est déroulée sans erreur (pas de problème PHP ou SQL )... mais lorsque j'ai voulu configurer les workspaces et utilisateurs, là ça coince:

Lorsque j'essaie d’accéder au workspace de l'utilisateur1 que je viens de créer dans "Paramètres" j'ai l'erreur:

Missing user in node URL

mais
- l'utilisateur administrateur peut lire/écrire/effacer/créer un dossier on "Fichiers commun" (stockés en D dans la structure représentée)
- l'utilisateur administrateur peut lire/écrire/effacer/créer un dossier dans "Mes fichiers" (stockés en C dans la structure représentée)

Pydio_structure.jpg.914bfffc48f3d6ad4c57b90811a38287.jpg

Je pense que c'est peut-être du à un problème de droits d'accès dans un htaccess ? ou le config.php? du CMS... mais que mettre et à quel niveau...  ou plus simplement la façon de remplir le champ "Path" pour workspace (J'ai essayé tellement de combinaisons sans succès).

Le dossier "normal" du sous-domaine (A dans la structure représentée) existe mais le DNS pointe direcement sur le dossier de l'installation Pydio folder (et ça marche puisque Pydio se lance correctement).

Le dossier contenant les dossiers des workspaces se trouve au même niveau que le dossier contenant l'installation Pydio (B dans la structure représentée).

Ça doit vous paraître mega basique comme question mais je suis complétement bloqué. Si une âme charitable pouvait me filer une petit coup de main avec des mots simple (bah oui je suis nul LOL) avant que je n'envisage un suicide :( ...

Par avance, merci.
Laurent.

Edited by LG92

Share this post


Link to post
Share on other sites

1 answer to this question

Recommended Posts

  • 0

Bonjour, 

A tout hasard, vous avez bien désactivé le paramètre "open_basedir " dans votre php.ini  ? Sans cela , il est impossible que PHP puisse aller en dehors du dossier "pydio" 
Par exemple B et A seront inaccessibles alors que D et C le seront parfaitement 

Juste une idée en passant :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×