Jump to content
  • 0
irahgis

De l'aide https pour un boulet sous WP svp

Question

Bonjour/Bonsoir à tous ceux qui liront ce message,

Et merci d'avance à ceux qui prendront le temps d'y répondre et qui chercheront à m'aider.

Tout est presque écrit dans le titre du post. Je galère à faire une chose sensée être simple à savoir passer un site WP en ssl.Bon, je suis pas totalement teubé, j'ai d'abord cherché une réponse sur le forum... J'ai donc, comme conseillé, généré le certificat Let's Encrypt avec le manager et celui-ci s'affiche bien dans "Dépôts certificats SSL" avec mon domaine à côté (avec et sans www)

J'ai d'abord installé "Really Simple SSL" en me disant, cool ça va être simple et vite fait l'histoire", le plugin une fois activé m'indique qu'il a bien repéré le certificat ssl et me propose d'activer le ssl. Ensuite, un message m'indique qu'il faut que je me reconnecte en https, eeeeeet là, c'est la cata, c'est la catastrophe.

C'est à partir de ce moment là que j'ai commencé à me transformer en minion...

J'ai perdu l'accès au site et j'ai dû désactiver le plugin dans la bdd avec phpmyadmin et j'ai du viré les https de "nom du site" et "homepage du site" pour récupérer la main.

Je repars de zéro, je me décourage pas, je teste les différentes configurations .htaccess trouvées sur le forum, et sur des sites "spécialisés tuto wp" idem, rien n'y fait, même délire.

Donc, j'ai sorti le legendario histoire de me calmer un peu et me voici en train d'écrire un message d'appel à l'aide ici voir si un maître Jedi pourrait sortir le jeune padawan que je suis de là...

Ah oui, j'oubliais, je suis en redirection HTTP+HTTPS sur iwal.

Voilà, donc si vous pouviez m'aider à retrouver ma forme originale et un peu d'estime de moi, je vous serais très, mais alors très très reconnaissant !

 

Share this post


Link to post
Share on other sites

17 answers to this question

Recommended Posts

  • 1

Bonjour à vous, 

Merci de répondre ! 

J'ai résolu mon problème ce matin, je n'ai pas pensé à mettre le topic en résolu.

Pour ceux qui se poserait la question un jour sur comment j'ai fait ?

La réponse est rien (pas de modif du .htaccess, ni de plugin à installer, etc.). Il n'y a rien à faire sur Yulpa pour passer son site WordPress en ssl, à part évidemment les 3 manipulations précitées à savoir:

  1. Générer un certificat Let's Encrypt
  2. Configurer la redirection HTTP+HTTPS
  3. Changer l'url du site et la page d'accueil en "https://lenomdusite.tld"

Mon problème venait du cache d'Opera je pense. J'ai encore quelques soucis de "contenu mixte" sur certaines pages, que je suis en train de résoudre grâce à la console du navigateur mais rien d'irrésolvable à première vue.

Voilà, en espérant que ça serve à quelqu'un.

Merci pour votre sollicitude Aurélien et pour vos services, j'en suis ravi depuis Web4all, vous êtes au top, rien à dire si ce n'est que du bien.

 

 

  • Upvote 1

Share this post


Link to post
Share on other sites
  • 0

Bonjour,

Irahgis, tu dis "

Il n'y a rien à faire sur Yulpa pour passer son site WordPress en ssl, à part évidemment les 3 manipulations précitées à savoir:

  1. Générer un certificat Let's Encrypt
  2. Configurer la redirection HTTP+HTTPS
  3. Changer l'url du site et la page d'accueil en "https://lenomdusite.tld"

En procédant juste de cette manière, je n'ai pas la redirection du http vers le https, est-ce qu'il y a une astuce ?

Manuel

 

Share this post


Link to post
Share on other sites
  • 0

Hello Manuel !

Vide le cache / tente avec un autre navigateur

 

PS: n'hésite pas à laisser un message pour dire si ça a fonctionné

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

Malheureusement, non, j'ai essayé au boulot et rien à faire, lorsque je tape  polybri.com  j'obtiens www.polybri.com,

il n'y a pas de redirection vers https://www.polybri.com

Ce qui me rend particulièrement confus, c'est qu'on trouve plusieurs procédures dans les forums, comme celle de Xhark proposée ici :

http://blogmotion.fr/systeme/htaccess-http-https-erreur-16358

Je l'ai tentée, sans plus de succès, mais c'est une procédure qui a plus de deux ans.  Ce que j'aimerais, c'est que quelqu'un m'indique tout simplement

une procédure qui fonctionne maintenant, en novembre 2019, pour forcer correctement le SSL.

Merci beaucoup en tout cas pour ta réponse, ça fait plusieurs jours que je suis bloqué, et c'est vraiment frustrant de ne pas pouvoir commencer à travailler

sur mon site.

 

 

 

Share this post


Link to post
Share on other sites
  • 0

Manuel

Chez moi ton site est en https et le certificat est bien celui de Let's Encrypt

Pour preuve; clique sur ton menu "Page d'exemple" et tu verras que tu es redirigé vers -> https://www.polybri.com/page-d-exemple/

Donc 95% de ton objectif est rempli !! Plutôt nice non ;)

À vue d'oeil je dirai que ça vient de ta config WP... Regarde dans les réglages du site quelle est l'url qui est renseignée. Tu dois avoir un truc du genre "nom du site" = Polybri | La traduction en contexte ....

Et ensuite une autre option avec "adresse du site" (ou de la page d'accueil de mémoire). Je pense que tu dois avoir "http:// au lieu de "https"

!Attention! Si c'est bien ça... Le site peut devenir injoignable ! Avant de paniquer; tente avec d'autres navigateurs pour voir si le problème persiste.

Si le site reste indispo; don't panic ! Tu peux toujours rattraper le truc en ouvrant la BDD avec phpMyAdmin (recherche "https// tu trouves la ligne et tu (re)modifies avec l'ancienne valeur)

Voilà !

Si ça marche pas; on verra comment faire ;)

 

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

Salut Irahgis,

Merci pour ta réponse.

J'avais bien veillé à indiquer les URL correctes dans l'administration de WP :

Adresse web de WordPress (URL)  
Adresse web du site (URL)  

C'est vraiment la redirection qui pose problème : les adresses www.polybri.com et http://www.polybri.com ne sont pas redirigées

vers https://www.polybri.com

 

 
   

 

Edited by shaluig

Share this post


Link to post
Share on other sites
  • 0

Effectivement, il n'y a pas de redirection. Pour se faciliter la tache avec un Wordpress, il y a un plugin que j'utilise également. Il fait le job et c'est trés facile d'utilisation : Really Simple SSL

Edited by Pascal
  • Like 1

Share this post


Link to post
Share on other sites
  • 0

Merci pour vos réponses !

Ok, vu pour le plugin. A vrai dire, Pascal, j'aimerais éviter : moins on ajoute de plugins, plus le site est fluide, je préfèrerais une solution "en dur" via le htaccess,

par exemple, mais ça reste une solution de recours, c'est une bonne idée.

 

Mon htaccess est le suivant (celui par défaut, je suppose) :

 

# BEGIN WordPress
# Les directives (lignes) entre 'BEGIN WordPress' et 'END WordPress' sont
# généré dynamiquement, et ne doivent uniquement être modifiées via les filtres WordPress.
# Toute modification des directives entre ces marqueurs sera outrepassée.
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>

# END WordPress
RewriteEngine on

 

Share this post


Link to post
Share on other sites
  • 0

Pascal, 

Voilà pourquoi je préfère éviter la solution du plugin :

https://reskator.fr/2019/really-simple-ssl-nest-pas-votre-ami/

Dans les commentaires, l'auteur de l'article indique lui-même :

"la redirection permet d’empêcher un utilisateur d’accéder au site en http.

Cela peut être mis en place via le fichier .htaccess (la solution la plus efficace et performante, mais pas toujours à la portée de tout le monde)."

On en revient donc au fichier .htaccess, c'est là qu'il va falloir que je trouve la solution.

Share this post


Link to post
Share on other sites
  • 0

Je progresse.

J'ai trouvé ce bout de code à ajouter au .htaccess, qui fonctionne lorsqu'on est sur Apache, et il me semble que les serveurs Yulpa sont sur Apache :

RewriteEngine on
RewriteCond %{HTTPS} off
RewriteRule ^(.*)$ https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]

Alors, là, bingo, lorsque je tape www.polybri.com ou http://www.polybri.com , j'ai une redirection immédiate sur https://www.polybri.com

Le seul souci, c'est que maintenant https://www.polybri.com n'est plus accessible :

 

 

 

bug.JPG

Share this post


Link to post
Share on other sites
  • 0

Niet, pas plus de succès avec ces deux solutions. 😶

 

Est-on bien d'accord sur un point : toutes les lignes de code citées dans les divers posts ci-dessous, je les rajoute bien après mon code initial ?

A aucun moment je ne dois remplacer mon code initial qui est le suivant, c'est bien ça ?

# BEGIN WordPress
# Les directives (lignes) entre 'BEGIN WordPress' et 'END WordPress' sont
# généré dynamiquement, et ne doivent uniquement être modifiées via les filtres WordPress.
# Toute modification des directives entre ces marqueurs sera outrepassée.
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>

# END WordPress
RewriteEngine on

 

Share this post


Link to post
Share on other sites
  • 0

Bon,    FIN DE L'HISTOIRE

alors que c'est indiqué "déconseillé" dans iWal dans la section "publication web du domaine", encart "Configuration SSL",

j'ai tenté "HTTP redirige sur HTTPS" , plutôt que "HTTP et HTTPS" pour le mode de publication.

Dans mon cas ça n'est pas gênant puisque je repars de zéro, pas d'anciennes URLs en http qui traînent, donc.

Et là....ça marche. Si ne pleuvait pas dehors, je pense que je serais allé faire le tour du pâté de maison 10 fois de suite en chantant "La cucaracha" à cloche-pied.

 

Je te remercie infiniment pour ta patience et tes conseils, Irahgis. Quand on bute sur un problème comme ça,

le fait d'obtenir des conseils, de tenter des trucs, ça incite d'autant plus à creuser et à creuser encore soi-même et à ne pas se décourager,

ça m'a été précieux.  5 jours, des heures et des heures de recherches et de tests, pour finalement cette solution toute simple,

j'espère que ça pourra en aider d'autres à gagner du temps.

Bon dimanche à tous,

Manuel

Share this post


Link to post
Share on other sites
  • 0

Passer des heures sur un truc pour enfin trouver une solution toute simple je connais !

Ceci dit une fois le Graal obtenu il y a ce sentiment de satisfaction intérieure qui vient après et qui est fort appréciable

Enfin ravi que tu aies trouvé une solution j'espère aussi que cela servira à d'autres !

  • Like 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...